[Qutecsound-users] CsoundQt 0.9.2 Build on Arch Linux

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Qutecsound-users] CsoundQt 0.9.2 Build on Arch Linux

Mitch Kaufman
Tarmo,

Moving this to the CsoundQt list as requested. Further clarification, that there is no error. The program freezes. I'll also check out ldconfig. Another note is that I've built Csound in my local home directory with the bin, lib and include files there which CsoundQt should refer to. 

Thanks for the help. 

Hi!

Would you mind joining CsoundQt mailing list?

https://lists.sourceforge.net/lists/listinfo/qutecsound-users

It is fine to aks about CsoundQT here, but the other one is more specified (and I would like to have more people actively using it ;) )

When crash happen on Run, probably some of the csound libraries or its plugins are not found.

Sometimes a simple $ sudo /sbin/ldconfig
is enough to refresh the list of newly compiled system libraries.

When you run CsoundQt from console. What is your output? Do you see any error messages?

Let know, how it goes!

tarmo

2016-04-05 20:38 GMT+03:00 Mitch Kaufman <[hidden email]>:
Hi,

I managed to get a CsoundQt executable produced on Arch with rtmidi after several tries in adding Qt5 modules to my system.  However, after CsoundQt comes up whenever I press any of the buttons such as Run or Run in Term, the application freezes.    I built this using qmake and not the qtcreator.

Does anyone have any thoughts on how to debug this?

Regards,
Mitch
Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

------------------------------------------------------------------------------

_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qutecsound-users] CsoundQt 0.9.2 Build on Arch Linux

Andres Cabrera
Administrator

I had this problem recently and I traced it down to the stk Opcodes. I suspect there was some binary incompatibility from older builds. Can you try removing the plugin Opcodes and then putting then back one by one?

Cheers,
Andrés

On Apr 5, 2016 4:30 PM, "Mitch Kaufman" <[hidden email]> wrote:
Tarmo,

Moving this to the CsoundQt list as requested. Further clarification, that there is no error. The program freezes. I'll also check out ldconfig. Another note is that I've built Csound in my local home directory with the bin, lib and include files there which CsoundQt should refer to. 

Thanks for the help. 

Hi!

Would you mind joining CsoundQt mailing list?

https://lists.sourceforge.net/lists/listinfo/qutecsound-users

It is fine to aks about CsoundQT here, but the other one is more specified (and I would like to have more people actively using it ;) )

When crash happen on Run, probably some of the csound libraries or its plugins are not found.

Sometimes a simple $ sudo /sbin/ldconfig
is enough to refresh the list of newly compiled system libraries.

When you run CsoundQt from console. What is your output? Do you see any error messages?

Let know, how it goes!

tarmo

2016-04-05 20:38 GMT+03:00 Mitch Kaufman <[hidden email]>:
Hi,

I managed to get a CsoundQt executable produced on Arch with rtmidi after several tries in adding Qt5 modules to my system.  However, after CsoundQt comes up whenever I press any of the buttons such as Run or Run in Term, the application freezes.    I built this using qmake and not the qtcreator.

Does anyone have any thoughts on how to debug this?

Regards,
Mitch
Csound mailing list
[hidden email]
https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND
Send bugs reports to
        https://github.com/csound/csound/issues
Discussions of bugs and features can be posted here

Csound mailing list [hidden email] https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND Send bugs reports to https://github.com/csound/csound/issues Discussions of bugs and features can be posted here

------------------------------------------------------------------------------

_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users


------------------------------------------------------------------------------

_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qutecsound-users] CsoundQt 0.9.2 Build on Arch Linux

Tarmo Johannes
In reply to this post by Mitch Kaufman

Welcome, Mitch!

 

Can you give more information - what version of Csound are you using? How did you install it? I guess Csound by itself is working fine?

 

Can you run the CsoundQt executable in terminal, can you see output something like:

 

$ ././CsoundQt-d-py-cs6-debug                                 
0dBFS level = 32768.0
Csound version 6.07 (double samples) Mar 17 2016
libsndfile-1.0.25-exp
end of score.              overall amps:      0.0
          overall samples out of range:        0
0 errors in performance
Elapsed time at end of performance: real: 0.000s, CPU: 0.000s
QObject::connect: No such slot WidgetPanel::dockStateChanged(bool) in ../qutecsound-code/src/widgetpanel.cpp:34
QObject::connect: No such signal FileBEditor::textChanged() in ../qutecsound-code/src/documentview.cpp:53
QObject::connect:  (sender name:   'FileBEditor')
QObject::connect: No such signal FileBEditor::textChanged() in ../qutecsound-code/src/documentview.cpp:53
QObject::connect:  (sender name:   'FileBEditor')
QObject::connect: No such slot DocumentPage::evaluate(QString) in ../qutecsound-code/src/documentpage.cpp:1188
CsoundQt::setWidgetPanelGeometry() Warning: width invalid.
CsoundQt::setWidgetPanelGeometry() Warning: height invalid.
QObject::connect: No such signal FileBEditor::textChanged() in ../qutecsound-code/src/documentview.cpp:53
QObject::connect:  (sender name:   'FileBEditor')
QObject::connect: No such slot DocumentPage::evaluate(QString) in ../qutecsound-code/src/documentpage.cpp:1188
WidgetLayout::loadXmlWidgets Older Widget Format version
DocumentPage::getMacOptions() Option Options:  not found!
DocumentPage::applyMacOptions() no Geometry!
<MacOptions> loaded.

Do you get any output when the crash happens?

 

or can you sart in the debugger (of course with your executable name)

 

$ gdb CsoundQt-d-py-cs6-debug
(gdb) run

 

After crash happens enter for backtrace:

 

(gdb) bt

 

 

Could you also have look what libraries is CsoundQt using and if there isn't anything strange:

 

$ ldd CsoundQt-d-py-cs6-debug

 

tarmo

 

 

 

On Tuesday 05 April 2016 19:29:43 Mitch Kaufman wrote:

> Tarmo,

>

> Moving this to the CsoundQt list as requested. Further clarification, that

> there is no error. The program freezes. I'll also check out ldconfig.

> Another note is that I've built Csound in my local home directory with the

> bin, lib and include files there which CsoundQt should refer to. Thanks for

> the help.

> Hi!

>

> Would you mind joining CsoundQt mailing list?

>

> https://lists.sourceforge.net/lists/listinfo/qutecsound-users

>

> It is fine to aks about CsoundQT here, but the other one is more specified

> (and I would like to have more people actively using it ;) )

>

> When crash happen on Run, probably some of the csound libraries or its

> plugins are not found.

>

> Sometimes a simple $ sudo /sbin/ldconfig

> is enough to refresh the list of newly compiled system libraries.

>

> When you run CsoundQt from console. What is your output? Do you see any

> error messages?

>

> Let know, how it goes!

>

> tarmo

>

> 2016-04-05 20:38 GMT+03:00 Mitch Kaufman <[hidden email]>:

> Hi,

>

>

>

> I managed to get a CsoundQt executable produced on Arch with rtmidi after

> several tries in adding Qt5 modules to my system. However, after CsoundQt

> comes up whenever I press any of the buttons such as Run or Run in Term,

> the application freezes. I built this using qmake and not the qtcreator.

>

>

>

> Does anyone have any thoughts on how to debug this?

>

>

>

> Regards,

>

> Mitch

>

> Csound mailing list

>

> [hidden email]

>

> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND

>

> Send bugs reports to

>

> https://github.com/csound/csound/issues

>

> Discussions of bugs and features can be posted here

>

>

>

> Csound mailing list

> [hidden email]

> https://listserv.heanet.ie/cgi-bin/wa?A0=CSOUND

> Send bugs reports to

> https://github.com/csound/csound/issues

> Discussions of bugs and features can be posted here

 


------------------------------------------------------------------------------

_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qutecsound-users] CsoundQt 0.9.2 Build on Arch Linux

Mitch Kaufman
Thanks.

I decided that I would start from scratch.  I had originally built to the current Csound 6.07 version using the "General Instructions for Linux without Root access."  My original objective was to build a system that would allow me to use CsoundQt and blue (which requires Java API access and was not successful in installing).  So I'm going to start over with that and when I have a problem again, I'll get back to you.  I've reinstalled a working Csound 6.06-1/CsoundQt 0.9.0-3 through Arch AUR so I can at least continue to make music while I try this build.

Regards,
Mitch

------------------------------------------------------------------------------

_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Loading...