Quantcast

[Qutecsound-users] csound64.dll.5.2 error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Qutecsound-users] csound64.dll.5.2 error

Michael Saunders
Windows Vista (64)
Python version 3.4.1
Csound version 6.03.2

I'm very anxious to upgrade to CsoundQT 0.8.3 from 0.8.2 because I often experience crashes that don't seem to depend on the code---sometimes the exact same code crashes at one time and runs fine at another, even though there are no random elements involved.  I'm hoping that the new CsoundQT may solve this.

I've tried installing with CsoundQt-0.7.0-install-win32-d.exe, and everything seems to be normal, but when I try to launch CsoundQT, I get:

"The procedure entry point csoundScoreEventAbsolute could not be located in the dynamic link library csound64.dll.5.2"

What can I do?

------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qutecsound-users] csound64.dll.5.2 error

Andres Cabrera
Administrator
Hi Michael,

I think that might mean that CsoundQt 0.7.0 was built for Csound5.

I'm interested in following up on your crashes. Do they happen in the middle of performance, when you start or stop a performance, or just randomly. Do they happen soon after starting CsoundQt, or at any moment? Do they seem to happen more often with certain csds or configurations?

Cheers,
Andrés


On Thu, May 29, 2014 at 1:58 PM, Michael Saunders <[hidden email]> wrote:
Windows Vista (64)
Python version 3.4.1
Csound version 6.03.2

I'm very anxious to upgrade to CsoundQT 0.8.3 from 0.8.2 because I often experience crashes that don't seem to depend on the code---sometimes the exact same code crashes at one time and runs fine at another, even though there are no random elements involved.  I'm hoping that the new CsoundQT may solve this.

I've tried installing with CsoundQt-0.7.0-install-win32-d.exe, and everything seems to be normal, but when I try to launch CsoundQT, I get:

"The procedure entry point csoundScoreEventAbsolute could not be located in the dynamic link library csound64.dll.5.2"

What can I do?

------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users



------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qutecsound-users] csound64.dll.5.2 error

Michael Saunders
In reply to this post by Michael Saunders
They can happen any time during performance, but not consistently.  I'm not sure what "certain csds or configurations" are. I'd like to find a minimal example for you, but I don't think I can. They didn't start happening until my orchestra reached a certain complexity. Sometimes (as today) the exact same code that ran earlier crashes time after time. Sometimes the opposite happens---if I keep trying, the same orchestra and score that crashed on one run works fine on the next. Thank you


------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qutecsound-users] csound64.dll.5.2 error

Andres Cabrera
Administrator
Hi,
Thanks for the information. It sounds like there is some sort of threading issue. I'm not sure whether moving to 0.8.3 would solve it, as I don't think there has been any changes in that respect. Have you tried removing the opcodes that use fltk? (move libwidgets.dll, libfluidSynth.dll, libvirtual.dll out of the plugins folder). I wonder if those are still causing problems.

Cheers,
Andrés


On Thu, May 29, 2014 at 2:44 PM, Michael Saunders <[hidden email]> wrote:
They can happen any time during performance, but not consistently.  I'm not sure what "certain csds or configurations" are. I'd like to find a minimal example for you, but I don't think I can. They didn't start happening until my orchestra reached a certain complexity. Sometimes (as today) the exact same code that ran earlier crashes time after time. Sometimes the opposite happens---if I keep trying, the same orchestra and score that crashed on one run works fine on the next. Thank you


------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users



------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qutecsound-users] csound64.dll.5.2 error

Michael Saunders
In reply to this post by Michael Saunders

I didn't find exactly those .dlls, but I found these: fluidOpcodes, virtual, and widgets in Csound6/plugins64 and I removed them (I'm pretty sure I'm not using any opcodes that depended on them).  Now it crashes the moment performance begins without even anything printed to the console.

Thank you,
- m

------------------------------------------------------------------------------
Time is money. Stop wasting it! Get your web API in 5 minutes.
www.restlet.com/download
http://p.sf.net/sfu/restlet
_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Qutecsound-users] csound64.dll.5.2 error

Michael Saunders
Might it help if I sent you the dump file (it's 147MB), from a typical run that crashes sometimes and completes others?


On Thu, May 29, 2014 at 7:19 PM, Michael Saunders <[hidden email]> wrote:

I didn't find exactly those .dlls, but I found these: fluidOpcodes, virtual, and widgets in Csound6/plugins64 and I removed them (I'm pretty sure I'm not using any opcodes that depended on them).  Now it crashes the moment performance begins without even anything printed to the console.

Thank you,
- m


------------------------------------------------------------------------------
Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and their
applications. Written by three acclaimed leaders in the field,
this first edition is now available. Download your free book today!
http://p.sf.net/sfu/NeoTech
_______________________________________________
Qutecsound-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/qutecsound-users
Loading...